Home > Announcements > Meter Readings 4.3 now available

Meter Readings 4.3 now available

November 15, 2015

mricon57 Minor fixes as a result of the iOS 9 update.

Note that you now require iOS 7.0 or above. Older versions (of iOS and my app) will continue to work, but you will no longer get updates. Full details are on my website.